Support Centre

Why Do I Get A "Map Not Referenced" Error When Importing A Map Into The Avenza Maps App?

Last Updated: Nov 23, 2017 11:34AM EST
 

This error occurs when the map has not been georeferenced, meaning no real-world coordinates have been assigned to the map document. Georeferencing is the process of aligning geographic data to a known coordinate system using known real-world locations. There are several ways location information can be obtained as shown in the above image. For instance, a surveyor could collect ground control points using a GPS data logger to record identifiable features on a map like utility poles or building corners and the coordinates of these control points would be associated with those features on a map. Another option is using spatial information from the map itself to georeference it. For example, a scanned map may have a grid showing lines of latitude and longitude. Lastly, another common method is collecting the coordinates from previously referenced spatial data like digital road networks or aerial imagery. Georeferencing is a common operation in Geographic Information System (GIS) software and there are several programs you can use to do this.

 

GIS software with georeferencing capabilities

 

  • MAPublisher is Avenza's solution for creating high quality maps using Adobe Illustrator's powerful graphics editing software. It can be used to georeference PDF or image files. It can also be used to export geospatial PDF files compatible with the Avenza Maps app. A two-week trial is available for new users. See this blog post for help with the MAPublisher Georeference tool.
  • Geographic Imager is Avenza's plug-in for Adobe Photoshop for working with raster imagery. As with MAPublisher, it can be used to georeference images and PDF files and export geospatial PDF files compatible with the Avenza Maps app. A two-week trial is available for new users. See the online help for instructions on using the Georeferencing tool.
  • Global Mapper is an affordable GIS application that gives users access to a wide variety of spatial datasets and GIS tools. The spatial datasets include imagery and topographic maps and is very useful as source data for Georeferencing maps. The Image Rectifier tool can be used to georeference PDF files and images. See the online tutorial for instructions on using this tool.
  • ArcGIS is one of the largest and most popular commercial GIS applications. It cannot be used to load and georeference PDF files, but it can be used to georeference image files which can then be saved to geospatial PDF. See the ArcGIS online help for instructions on georeferencing. To georeference a PDF file using ArcGIS you must first convert the file to an image. This can be done using the PDF to TIFF (Conversion) tool which is available with an ArcGIS Basic license.
  • QGIS is a popular free and open source GIS application with a wide array of built in tools and downloadable plug-ins. Georeferencer is one of the included plug-ins. See the online tutorial on how to use this tool.

 

 

How do I make my map compatible with Avenza Maps when exporting from GIS software?

To make a properly referenced map for use with the Avenza Maps app, it must be exported as a geospatial PDF or a GeoTIFF file; both of which are file formats with spatial information embedded in the file. Most GIS software is capable of exporting to these formats.

 

  • MAPublisher: on the MAPublisher Toolbar, select Export > Export Document to Geospatial PDF. To export as GeoTIFF, select Export > Export Document to Image and choose TIFF with GeoTIFF as the reference format.
  • Geographic Imager: on the Geographic Imager panel toolbar drop-down menu, select Quick Save to Format > Geospatial PDF or GeoTIFF.
  • Global Mapper: by default, it exports to geospatial PDF when exporting the map to PDF file. Select File > Export > Export PDF File. To export the map as GeoTIFF, select File > Export > Export to Raster/Image Format and select GeoTIFF from the drop-down list.
  • ArcGIS: select File > Export Map. When exporting to PDF select Advanced > Export Map Georeference Information. When exporting to GeoTIFF, select Format > Write GeoTIFF Tags.
  • QGIS: first export the map to an image by selecting Project > Save as Image and save the map canvas as a TIFF file. Next, select Raster > Conversion > Translate (Convert Format) and in the dialog box select the map image as the Input Layer, choose an Output File location, then check Target SRS and select an appropriate coordinate system. The Translate tool can export to GeoTIFF and geospatial PDF.

 

 

Documents with more than one map on a page

Sometimes PDF documents will have two or maps on a layout, such as inset maps or key plans. Typically, in this case, the georeferencing will apply to the largest map frame on the layout. Occasionally there will be an error where the GPS location will be on a map other than the main map. If this happens, there are a few possible solutions:

 

  • If you are producing your map using GIS software, save the inset or key map as an image and insert it into the map layout. This will ensure that there is only one spatially reference map in the document so there is no chance of getting the georeferencing information from the wrong map.
  • Export only the main map to geospatial PDF or GeoTIFF and not any of the inset or key plan maps.
  • Georeference the map manually using any of the methods described above.

 

 

470780163d9e7375078734b8b53cc574@avenza.desk-mail.com
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete